Summary

PARACHUTES is a computer program developed at the International Center for Numerical Methods in Engineering (CIMNE) for the unsteady simulation of ram-air (gliding) parachutes. The simulation software is based on an unsteady low-order panel method, which is used for solving the aerodynamics of the gliding parachute, and a finite-element model of the structure. PARACHUTES solves in a coupled manner the fluid-structural problem governing the behavior of arbitrary parachute-payload configurations under specified flight conditions, and also allows analyzing user-defined maneuvers. The present document describes the user’s interface developed for PARACHUTES on the basis of the CIMNE’s pre and post-processor system GiD. A tutorial intended to demonstrate how to set up and run a typical parachute problem is also presented.
# Table of Contents

1. Introduction ............................................................................................................................. 3
2. Overview of the graphical user interface ................................................................................ 3
   2.1 Initial considerations ...................................................................................................... 4
       2.1.1 Definition of units ....................................................................................................... 5
   2.2 Procedure to solve a problem with PARACHUTES ...................................................... 5
3. Configuring a simulation ......................................................................................................... 6
   3.1 Boundary conditions ...................................................................................................... 7
       3.1.1 Aerodynamic boundary conditions ............................................................................ 7
       3.1.2 Structural boundary conditions .................................................................................. 8
   3.2 Materials ........................................................................................................................ 9
   3.3 Problem parameters .................................................................................................... 11
       3.3.1 General options ....................................................................................................... 12
       3.3.2 Reference conditions ............................................................................................... 13
       3.3.3 Input/Output options ................................................................................................ 14
       3.3.4 Aerodynamics parameters ...................................................................................... 15
       3.3.5 Structural parameters .............................................................................................. 18
4. Tutorial on using PARACHUTES ......................................................................................... 19
   4.1 Model pre-process ....................................................................................................... 20
       4.1.1 Loading the ProblemType ....................................................................................... 20
       4.1.2 Creating or importing the model geometry .............................................................. 20
       4.1.3 Assignment of boundary conditions ........................................................................ 21
       4.1.4 Defining the model materials ................................................................................... 26
       4.1.5 Meshing the model .................................................................................................. 30
   4.2 Configuring the simulation (Problem Data) .................................................................... 32
   4.3 Executing and monitoring the simulation .................................................................... 33
   4.4 Post-processing results ............................................................................................... 35
       4.4.1 Example of simulation results .................................................................................. 36
       4.4.2 Animations ............................................................................................................... 39
5. Registering PARACHUTES ................................................................................................. 39
6. Conclusions .......................................................................................................................... 40
References .................................................................................................................................. 40
1 Introduction

PARACHUTES is a research simulation software developed at the International Center for Numerical Methods in Engineering (CIMNE) for the design and analysis of ram-air type parachute-payload systems. The computer program solves the aerodynamic and structural problems governing the behavior of the parachute-payload system in a coupled manner. The solver consists of two unsteady calculation modules, aerodynamic and structural, which are sequentially advanced in time in an explicit manner exchanging data at each time step (a 2-way staggered coupling is used). The aerodynamics is solved with a low-order panel method and a finite element technique is used for the structure. The latter allows modelling the suspension lines, textile fabric and suspended payloads of a typical parachute system by means of cable, membrane and solid linear elements. The solution methodology adopted in PARACHUTES is described in detail in the Program Theory Manual [1]. In the present document, the graphical user interface (GUI) implemented into the GiD pre and post-processing software [2] is presented, as well as an example of application to the solution of a typical parachute problem.

This document is organized as follows. An overview of the graphical user interface developed to facilitate the use of PARACHUTES is described in Section 2. The different boundary conditions, material properties and problem parameters needed to configure a simulation are explained in Section 3. A tutorial aimed at describing the typical procedures to set up and run a parachute simulation is presented in Section 4. Considerations regarding the code license needed to profit from the full capabilities of the software are given in Section 5. Finally, some conclusions are outlined in Section 6.

2 Overview of the graphical user interface

The graphical user interface (GUI) developed for the PARACHUTES program is presented in this section. The interface is implemented into the in-house pre- and post-processing software GiD [2], and allows the configuration of the solver input geometry and parameters, run the simulation and analysis of the results. The GUI facilitates the use and evaluation of the code, maintaining most of the functional features included in its research version. With this interface, the user also profits from all the tools available in GiD for importing, creation and reparation of geometry, mesh generation and visualization of results. It should be noticed that the latest advances in the research version are gradually introduced in the user interface as they are successfully tested.
2.1 Initial considerations

The graphical user interface is loaded into GiD through the so-called *problemtype*. The problemtype consists in a folder named **PARACHUTES.gid** which contains the configuration files required for the interface, the program binaries and help documents. This folder must be placed inside the GiD problemtype directory. The latter is usually located in `C:\Program Files\GiD\GiD 12.0.3\problemtype`, but the path may depend on the installed version. Shortcuts and symbolic links are also supported.

Once the folder **PARACHUTES.gid** has been placed in the GiD problemtype directory, the parachute problemtype should appear on the GiD data menu (Figure 1). After selecting the corresponding menu item, PARACHUTES will be loaded into GiD and assigned to the current user’s project. If the latter already has a PARACHUTES.gid problemtype assigned, GiD allows a replacement or an upgrade. It is important to note that when the problemtype is replaced, the model parameters and boundary conditions assigned to the project are deleted. Conversely, the upgrade operation will try to keep the data assigned to the project (GiD attempts to merge the old problemtype data parameters into the new version). To avoid potential conversion problems, a replacement is generally recommended.

![GiD x64 Project: Parachute](image)

*Figure 1. Loading the parachute problemtype.*

After loading the problemtype PARACHUTES, the data menus required to configure the simulation, namely **Conditions**, **Materials** and **Problem Data**, will be available inside GiD (see Figure 2). In addition, a toolbar with shortcuts to each module has also been implemented for convenience (note that the entries on both the toolbar and the menus are equivalent). All the input data of the program can be defined through the **Conditions**, **Materials** and **Problem Data** modules. The **Conditions** module allows defining the problem boundary conditions required by the Aerodynamic and the Structural analysis; the **Materials** module allows setting the properties of several pre-
defined materials and assigning them to the model. The **Problem Data** module allows configuring the parameters controlling the simulation.

![Configuration menus and toolbar](image)

**Figure 2. A view of the configuration menus and the toolbar.**

### 2.1.1 Definition of units

In PARACHUTES there are not pre-established units to define dimensional quantities such as length, mass, forces, pressures, etc. The program only requires that the set of units employed in the model geometry, material properties and simulation parameters is consistent. For example, if the base units used in the simulation are meter, kilogram and second (MKS), derived quantities like velocity should be in m/s, the force in newton, pressure and stress in pascal, the mass density in Kg/m³ and so on. The units of the dimensional output variables will be according to the input data.

### 2.2 Procedure to solve a problem with PARACHUTES

Once defined how the data is laid out, the procedure to run PARACHUTES inside the GiD environment can be summarized in the following basic steps:

1. If PARACHUTES is not yet installed, or an upgrade must be done, copy or replace the problemtype folder to the GiD_Install_Dir/problemtype directory.
2. Import or create the model geometry into GiD. Several CAD formats are supported, refer to GiD documentation for further details [2].
3. Load the parachute problemtype (menu “Data → Problemtype → parachute”).
4. Apply the aerodynamic/structural boundary conditions and materials on the model using the corresponding modules (menu “Data → Conditions → Aerodynamic/Structural”, and menu “Data → Materials”).
5. Generate the mesh (refer to GiD help for the available meshing options). Note that the mesh must be re-generated whenever a change is made to the boundary conditions and/or materials applied (these changes are not automatically translated into the mesh).

6. Set the simulation parameters (menu “Data \(\rightarrow\) Problem Data”).

7. Run the program (menu “Calculate \(\rightarrow\) Run”, or menu “Calculate \(\rightarrow\) Calculate window... \(\rightarrow\) Start”, or press the F5 key). If the runtime output is to be displayed, click on menu “Calculate \(\rightarrow\) View process info...”

After or during the execution it is possible to switch to GiD's post-processing mode and load the available results for visualization or analysis purposes. To this end, GiD uses two different files, one with extension .msh which contains the mesh geometry, and another with extension .res with the results to be displayed. The program PARACHUTES writes these output files separately for the aerodynamic and structural calculation modules. Hence, in the user’s project directory you will find a set of files: project_name_aero.post.res/msh for the aerodynamic results, and project_name_pumi.post.res/msh for the structural results.

The program also writes other data useful for the analysis of the simulation in separated text files. The file project_name.forces.dat displays the time history of the aerodynamic forces acting on the model (pressure forces), as well as additional values useful for analyses such as the evolution of the center of mass of the model and the reference dynamic pressure. The file project_name.velocity.dat contains the time history of the velocities and displacements of the model's center of mass, as well as inertia data. The file project_name_pumi.viscfor.dat shows the time history of the viscous dissipative forces. This information is useful to adjust the numerical damping added to the model to control spurious oscillations (see details in [3]). The magnitude of the total viscous forces should be small compared to the values of the characteristic forces acting on the problem (for example the weight). Otherwise the structural response could be affected by the numerical dissipation.

3 Configuring a simulation

The data menus Conditions, Materials and Problem Data required to configure a simulation are explained in this section.
3.1 Boundary conditions

The boundary conditions are defined separately for the aerodynamics and the structure. Both submenus can be found under the “Data → Conditions” menu, or accessed directly from the main toolbar. The different types of boundary conditions are explained below.

3.1.1 Aerodynamic boundary conditions

Figure 3 shows several of the aerodynamic boundary conditions to be prescribed on points, lines and surfaces.

![Aerodynamic boundary conditions](image)

Figure 3. Aerodynamic boundary conditions.

The available aerodynamic boundary conditions are:

- **Body axis reference**: Origin of the model local axes. The body axes are assumed coincident with the model axes. The coordinates of this point can also be defined in the 'Problem data' window. If a coupled simulation is performed, this value is automatically replaced by the center of mass of the model. This point is used as a reference to compute aerodynamic moments, trajectory, etc.

- **Trailing edge**: This condition should be applied along the trailing edge of aerodynamic lifting surfaces and flow separation lines. If there is more than one trailing edge, these must be identified by using different indexes because the code will generate a continuous row of wake panels along trailing lines having the same index. It is not needed a continuous numbering. It is important for a proper geometrical representation of the trailing edges to ensure each line composing the same trailing edge is oriented in the same direction. This can be verified on the model geometry (GiD pre-process mode) by using the command “view → normal → lines”. The direction of a given line can be changed by “utilities → swap normal → lines”.

- **Panel type**: Identifies aerodynamic surfaces according these conform an enclosed internal volume (thick panels), or they are isolated surfaces where the thickness goes to zero, e.g. a sheet or a piece of fabric (thin panels). Thick
surfaces are represented by the aerodynamic solver by using constant source-doublet elements, and constant doublet elements are used for the thin surfaces. Thick surfaces must be defined in such a way that its normal vector points outside the body (exterior normal definition). If needed, the surface normal can be inverted with the GiD the command “utilities → swap normals → surface”.

- **Compute forces**: Indicates surfaces where the pressure contributions should be integrated to compute the resultant aerodynamic forces and moments. Different numbers can be assigned to each part of the model in order to separate the different contributions. Consecutive numbering is not required.

- **Experimental forces**: This condition allows prescribing aerodynamic force functions (for example from experimental data fitting) to bodies modelled as rigid. This allows accounting for its aerodynamics in an inexpensive way. By the time being only drag is considered in PARACHUTES, and the functions must be given in the form $D_{body}/q/A_s = A x^2 + B x + C$, where $x = A_{projected}/A_s$, $A, B, C$ are adjustment coefficients and $A_s$ is the body reference area. In order to apply prescribed forces on a body, the surfaces enclosing the latter should have the same index number. This value is also used to identify the corresponding force function (see Section 3.3.4). Consecutive numbering is not required.

### 3.1.2 Structural boundary conditions

Figure 4 illustrates several of the structural boundary conditions to be prescribed on points, lines, surfaces and volumes.

![Figure 4. Structural boundary conditions](image-url)
The structural conditions that can be applied on those elements are:

- **Fixed point**: Constrain displacement of points in the structure.
- **Cable load**: Assign a constant load along the cables (force per unit length).
- **Cable strain**: allows prescribing time cable deformation in order to simulate maneuvers. Time deformation is introduced in tabular form, the columns are time and deformation, and the number of rows corresponds with the number of deformation steps to be applied (note that the last deformed configuration is frozen during the overall simulation time). The amount of deformation is defined by the parameter epsilon, which is computed as the ratio between the desired deformation ($\Delta l$) and the initial length of the cable ($l_0$). The transition between one deformation step to another is performed through a smooth time variation function, see additional details in [3].
- **Rigid line**: Converts the cable into a rigid body, i.e. the set of elements composing the cable are modeled as a rigid body. This is usually applied when the deformation of the elements is negligible, and allows reducing considerably the degrees of freedom of the problem and the computational cost. The geometrical entities composing the same body must have the same id.
- **Rigid surface**: Converts the surface into a rigid body, i.e. the set of elements composing the surface are modeled as a rigid body.
- **Rigid body**: Converts the volume into a rigid body, i.e. the set of elements composing the volume are modeled as a rigid body (this option is typically used to model suspended payloads).
- **Face pressure**: Allows applying a constant pressure force (dimensional) on a surface. This condition can be applied, for instance, to model the parachute inlet surfaces. In such a case, zero pressure should be prescribed (see Program Theory Manual [1] for further information about canopy air inlets).

### 3.2 Materials

The program PARACHUTES allows modelling cables, membranes and solid structural linear materials using 2-node, 3-node and 4-node finite elements, respectively. Each material or structural element is characterized by a set of properties described below.

- **Membrane**: Thickness, Cd, Density, Rayleigh alpha, Rayleigh beta, Young's modulus, Poisson's ratio.
- **Tetra**: Density, Rayleigh alfa, Rayleigh beta, Young's modulus, Poisson's ratio.
- **Cable**: Diameter, Cd, Density, Rayleigh alfa, Rayleigh beta, Young's modulus.
• **Reinforcement**: Equivalent diameter, Cd, Density, Rayleigh alfa, Rayleigh beta, Young's modulus.

The definition of materials is necessary only for structural analyses. This is performed in the menu **Materials** (Figure 5), where different templates are defined for each type of structural element available. Additional materials can be created using the provided templates ("New material" menu button), for example if several types of cables, fabrics or solid materials are needed.

![Figure 5. Materials module](image)

A general description of the physical parameters required to model the different materials available in PARACHUTES is given below:

- **Thickness**: Element thickness.
- **Diameter**: Cable diameter.
- **Equivalent diameter**: This is used to model fabric reinforcements which usually have not circular cross-section. Internally these elements are modelled as a cable with an equivalent diameter (e.g. of a circle having the same cross-sectional area).
- **Cd**: Aerodynamic drag coefficient. Used to compute aerodynamic loads (by the time being this option is only available for cables, which are modelled as long cylinders exposed to the wind).
- **Density**: Mass density of the material.
- **Rayleigh alpha**: Damping factor which controls the part of numerical dissipation which is proportional to the mass and the velocity of the structural element (see Program Theory Manual [1] for details of implementation and use). Small values of this parameter allow controlling spurious numerical oscillations, but higher values can modify considerably the response of the
structure (alpha damping affects the low frequency modes). For transient simulations, alpha must be chosen ensuring the damping ratio for the lowest mode is smaller than the critical damping factor. It is convenient to perform some tests in order to determine optimum values. Typically these should be lower than unit (e.g. 0.01 – 0.1) to preserve the transient response, but it is possible to increase these values if only the stationary long-term response is sought. Note that since the numerical dissipation is also proportional to the mass of the element, the behavior of heavy elements such as payloads is greatly affected

- **Rayleigh beta**: Damping factor proportional to the stiffness of the element that affects high frequency modes. A typical value could be $1 \times 10^{-5}$. Note that higher beta factors will have an impact on the stability margin, penalizing the allowable time step, see Program Theory Manual [1].

- **Young's modulus**: Material Young modulus. If wrinkling is allowed, the element will not support compressive loads.

- **Poisson**: Material Poisson ratio.

**Important note about damping control**: the dissipation forces introduced by the contribution of the mass and stiffness damping (alpha and beta) are proportional to the absolute velocity of the nodes. Therefore, these forces can greatly affect the behavior of structures that undergo significant rigid body motion. In order to minimize this undesirable effect (particularly for the $\alpha$-term which affects the lower modes), PARACHUTES has the ability to compute the dissipation force using velocities relative to the center of mass of the system (see Section 3.3.5). In this way, only the displacements relative to the global motion of the structure are damped. This also makes that the dissipation forces act in a local manner and tend to zero when the steady state is achieved. The use of relative damping allows increasing the value of the damping parameters without significantly affecting the global behaviour of the system.

**3.3 Problem parameters**

The simulation conditions and code setup parameters are organized under the *Problem Data* menu into five main sections named *General, Reference conditions, Input/Output, Aerodynamics* and *Structural* (see Figure 6). Note that some controls have a series of dependencies on others: for example, if the structural simulation control is deactivated all the structure-related controls will be hidden. This has been implemented to clean-up the interface and simplify the input process.
The data required at these sections are explained below. The several sub-levels on the lists reflect the dependencies between controls.

### 3.3.1 General options

- **Project name**: identification name to be used for the simulation output files.
- **Aerodynamic analysis**: select to run an aerodynamic simulation.
  - **Time steps**: total number of time steps for the aerodynamic simulation (it is also the same for coupled simulations).
  - **Time increment**: time increment in each aerodynamic step (this can be overwritten in coupled simulations).
  - **Number of cores**: number of execution threads (if cores > 1, will run a multi-threaded aerodynamic simulation). By this time only the aerodynamic solver is parallelized.
- **Structural analysis**: select to run structural simulation.
  - **Start at step**: time step (aerodynamic) at which structural computations will start. Only for coupled simulations.
  - **Max structural steps**: maximum number of structural steps. Only for coupled simulations.
  - **Structural calculus freq**: number of aerodynamic steps per each structural step use when solving the coupled simulation (usually this value is set to 1).
  - **Max time steps**: maximum time iterations allowed at each structural calculation step (since the stability margin of the structural code is small, several structural iterations are typically performed per aerodynamic
step). In general it is preferable to set this parameter to a large value and control the stop criteria of the solver by the maximum displacement. See note below.

**Note:** the structural solver has different stop criteria. First, it stops if \( \text{max\_time\_steps} \) iterations is reached; second, if the displacement of any point of the structure goes beyond a specified displacement tolerance; and finally, if the specified force residual level is reached (only works for stationary solutions). The stop criteria are defined in the structural conditions menu.

### 3.3.2 Reference conditions

- **Parachute initial velocity:** initial velocity of the model (center of mass). This is given in inertial (earth) system and this value is constant unless the structure is resolved. In a parachute simulation, this value is assumed to be approximately the airdrop or release velocity.
- **Wind velocity:** wind velocity components, in inertial (earth) system. Wind is required if the model has any fixed point.
- **Air density:** mass density of the air (constant). It is needed to compute the aerodynamic loads acting on the model.
- **Canopy internal \( \text{Cp} \):** coefficient of pressure to be applied inside the body in order to pressurize the canopy cells. See note below.
- **Gravity vector:** gravity acceleration vector, defined in inertial (earth) axes.
- **Start from restart file:** Starts the simulation from pre-calculated data stored in the file \( \text{project\_name\_rst} \) (basically, deformed configuration and velocities). This option should be used with care because no history of the model deformation is available. The restart option is not useful if cable deformation is applied during the simulation.

**Note about canopy internal pressure:** since from the structural point of view the parachute canopy is not closed (zero load is applied on the inlet panels), the internal pressure generates a non-zero net force which is mainly oriented in the axial direction, contributing to the parachute drag. In real problems, the internal airflow between cells and fabric porosity prevent from achieving stagnant conditions inside the canopy. Thus, if there is no a better estimate available, stagnation internal pressure or a slightly lower value can be used. Note that its drag contribution can be overestimated. See Program Theory Manual [1] for details.
3.3.3 Input/Output options

- **General**
  - **Restart file write frequency**: Write the restart file `project_name.rst` every # aerodynamic time steps.

- **Aerodynamic**
  - **Print aero results frequency**: Frequency (# aerodynamic steps) for writing aerodynamic results. Results will be written in the files `project_name_aero.post.res` and `project_name_aero.post.msh`.
  - **Print forces frequency**: Frequency (# aerodynamic steps) for computing aerodynamic forces and moments on the body. Results will be written in the following file: `project_name.forces.dat`. This frequency also applies to other data files (velocities, viscous forces, etc).
  - **Echo frequency**: Frequency (# aerodynamic steps) for displaying screen information during the simulation (time step, simulation time, CPU-time, solver iterations and convergence residuals).
  - **Overwrite aerodynamic results**: Overwrite existing results (files *.res and *.msh); otherwise append results.
  - **Print relative motions**: If activated, print deformation in body-fixed system. If deactivated, print deformation in inertial (earth) system.
  - **Print control loads**: Print dimensional forces applied to the structure at the beginning of each structural computation in a separate results file. Only for testing purposes.
  - **Print smoothed results**: Perform a smoothing procedure on the solution to obtain nodal values.

- **Structural**
  - **Force residuals check frequency**: Frequency (# structural steps) for checking the force residuals.
  - **Buffer struct results frequency**: Frequency (# structural steps) for buffering structural results into memory. The buffered results will be printed to file according to the value of the “Print struct results frequency” parameter.
  - **Print struct results frequency**: Frequency (# aerodynamic steps) for writing the buffered structural results to file. Only for coupled simulations. Results are written to the following files: `project_name_pumi_mem.post.mesh` and `_pumi_mem.post.res`.
It is important to note here that the current version of PARACHUTES writes the output results in ASCII files. Hence, the size of the output files can be considerable for runs involving a large simulation time. In such cases, the frequency used to print these files should be adjusted to the minimum required to perform the desired analysis.

3.3.4 Aerodynamics parameters

- **Coordinate origin**: Initial position of the body system's origin. Overwritten if defined as a boundary condition in 'Conditions' menu (see Section 3.1.1). If a coupled simulation is performed, this value is replaced with the center of mass of the model.

- **Parachute surface**: Reference surface area used for computing dimensionless force and moment coefficients and other operations requiring an estimate of the problem characteristic surface.

- **Parachute length**: Reference length value used for computing dimensionless moment coefficients and other operations requiring an estimate of the problem characteristic length.

- **Wake buffer length**: Maximum number of wake rows shed in the simulation (only the latest wake_buffer_length rows are conserved). See details on the wake modelling in the Program Theory Manual [1].

- **Wake relaxation coeff**: Limit the movement of wake nodes during the update of its spatial positions (wake rollup, see [1]). Value ranges from 0 to 1. If $\text{Wake relaxation coeff} = 0$ no wake rollup is performed. This option can be useful if there is problems due to the intersection of wake panels.

- **Solver**
  - **Solver type**: Linear solver for the solution of the aerodynamic influence coefficients' system. The options currently available are:
    1. *Direct solver using LU-factorization*. This approach is the most robust but requires a higher memory storage, which can impose some limitation in large problems. It should be noted that after performing some initial steps (which depend on the wake length), an iterative solution is attempted. If the problem geometry does not vary considerably between time steps, a few iterations are usually enough to converge to the new solution, and the computational time is reduced considerably if compared to the direct solution. If the iterative solution does not converge, the code switches back to the direct solver.
2. *Iterative Bi-Conjugate Gradient method.* It is much faster after the initial steps and requires less memory storage, but is also less robust. It should be noted that the convergence of the solver may be difficult to achieve (in a reasonable number of iterations) in complex models having high-aspect ratio (distorted) panels and presenting panels intersections during the computation.

3. *Direct LU solver.* It has lower memory consumption than solver (1), but is probably less robust. Despite this, this solver presents a better accuracy/cost ratio and is the option recommended for typical analysis.

4. Combines (2) and (3). An iterative solution is attempted with solver (2) using very few iterations. If the solution is not reached, the solver switches automatically to (3). Overall, this option is very similar to solver (1) but with lower storage requirements.

   - **Iter max BiCG:** Maximum number of iterations used as stopping criterion for the BiCG solver. Although this value depends on the problem size, usually 100-150 iterations should be enough to converge in typical models if the geometry is not very distorted.

   - **Tol BiCG:** Residual tolerance used as a stopping criterion for the BiCG iterative solver. The infinite norm of the residual vector is used (typically, satisfactory results are obtained with values from 1.0E-4 to 1.E-03).

- **Advanced**

  - **Smoothing tolerance:** Cosine of the maximum angle admissible between the normal vectors of panels considered to be adjacent. This value affects the nodal weighted averaging required to compute the loads on the aerodynamic panes (see Program Theory Manual [1]). A typical value is 0.6 (about 60 deg).

  - **Trailing edge correction:** Decreases the aerodynamic load linearly on each wing section, from \((1 - \text{value}) \times \text{chord}\) up to \(\text{chord}\). This control intends to reproduce to some extent the effect of detached flow in the rear part of the parachute, and helps to control some undesirable effects such as the excessive fluttering of the trailing edge of the parafoil. A typical value is about 0.3, but it depends on the airfoil characteristics.

  - **Farfield factor:** Constant factor defining the minimum distance between panels for which the far-field approximation is used when computing the influence coefficients (this reduces the computational cost when assembling the influence coefficients matrix). The minimum distance is
computed as: $\text{farfield\_factor} \times \text{panel\_characteristic\_size}$. A typical value is 5 (see Program Theory Manual [1] section 2.2.1.2).

- **Wake growth factor**: Increase the length of the wake panels linearly from 0 at the leading edge to $\text{Wake\_growth\_factor}$ at the downstream edge of the wake. If $\text{Wake\_growth\_factor} = 1$ no increase factor is applied. This control allows enlarging the wake length without increasing too much the number of wake panels (which increases the cost). It is useful when the problem advances with very small time increments (typical in parachute simulations). It should be noticed that this procedure does not conserve wake vorticity.

- **Time step increase factor**: Increase linearly the time increment at each time step. Values: [initial step, final step, value]

- **Safe derivatives**: Perform additional verifications on the original geometry in order to pre-establish panel adjacencies. Checks are also performed on the deformed geometry to guarantee a safe computation of derivatives on the body surface when computing aerodynamic loads. This control also includes additional checks to increase solution robustness and stability. Most of them activate if the solver solution does not converge. If this occurs during a large number of successive steps, the current solution may lack physical meaning due to the use of outdated information stored in previous steps.
  - **Cp lower bound**: this limits the minimum value of Cp passed to the structural solver. Note that the maximum Cp is adopted slightly above unity (incompressible flows).

- **Apparent mass** (experimental in this program version): compute parachute apparent mass using the model of Lissaman and Brown (see Program Theory Manual [1]). This model requires defining the following geometric information (estimated for the inflated configuration).
  - **Canopy span**: canopy span
  - **Canopy chord**: canopy chord
  - **Canopy arc**: canopy arc
  - **Canopy thickness**: canopy thickness

- **Payload coefficients**: Payload aerodynamic data to define prescribed drag functions: $\text{Body ID}$: Body number (references the ID defined in Structural → RigidBody); $\text{Aside}$: body largest side area; $A, B, C$: adjustment coefficients; $A_s$: body reference area ($D_{body}/q/A_s = Ax^2 +$
\[ Bx + C, \quad x = \frac{A_{\text{projected}}}{A_s}. \] The adjustments coefficients can be computed from experimental data fitting, see for instance [4].

### 3.3.5 Structural parameters

- **Mass scaling model**: Introduce local changes in the element density in order to keep the stability margin during the structural time integration within acceptable levels. Note that this can modify the total mass of the model slightly.

- **Stinc dispersion factor**: Number of standard deviations adopted for scaling the mass. Only elements beyond these limits will be affected.

- **Residuals convergence criteria**: Convergence criteria for the forces residual. Dimensionless number computed as the ratio between the force residual at a current step and the initial residual. The structural computation stops when this value is reached.

- **Max displacement**: Maximum displacement allowed during the structural computation (in length model units). The structural computation also stops when this value is reached.

- **Relaxation parameter \( F \)**: Constant factor (0 – 1) employed for under-relaxation of the aerodynamic forces applied on the model: \( f_{n+1} = (f_{n+1} - f_n) \times \text{factor} + f_n \). Typical values are 0.8–0.9, but should be used with care, especially if the dynamic behavior of the structure is of interest. This control only works for coupled simulations.

- **Relaxation parameter \( V \)**: Constant factor lower than unity employed for under-relaxation of the kinematic velocities passed from the structural to the aerodynamic solver. These are computed by \( v_{n+1} = (v_{n+1} - v_n) \times \text{factor} + v_n \). This control should be set to 1 in typical simulations. Values about 0.8–0.9 allow reducing to some extent the unsteadiness of the aerodynamic solution, but can also reduce the aerodynamic damping (affecting the convergence of the problem). Its use is not recommended unless the effects on the solution can be predicted and controlled. This control does not affect the velocity of the structure, and works only for coupled simulations.

- **Advanced**
  - **Bulk viscosity**: Fraction of the critical damping applied to the volumetric mode of each element. This value should be smaller than the unit in order to avoid penalizing the time step (typically 0.1 or less).
  - **Relative damping**: compute the mass and stiffness numerical damping using velocities relative to the center of mass of the model. This brings
the dissipation terms down to zero in the steady state and makes the numeric dissipation localized, which allows for large values of alpha and beta. The default value of this control is enabled (i.e., use relative velocities), otherwise the damping terms are computed using absolute velocities. See note in Section 3.2 for further information.

- **Extra alpha damping factor**: Extra alpha damping factor applied at the start of the simulation and progressively reduced in time. The value must be greater than 1.0, otherwise it is disabled. This control provides a larger amount of numerical dissipation during the starting moment, helping to the robustness and stability of the simulation. Note that since the deployment and inflation stages are not resolved by the code, the initialization of the problem may be unrealistic, and therefore the structure can undergo large displacements and oscillations during the starting process.

- **Alpha damping reduction rate**: Reduction factor per step applied to the extra alpha damping factor. Must be greater than 0.0

- **Cable safety factor**: Safety factor used to compute the allowable time increment in linear cable elements (typically 0.8-0.9).

- **Tria safety factor**: Safety factor used to compute the allowable time increment in triangle elements (typically 0.8-0.9).

- **Tetra safety factor**: Safety factor used to compute the allowable time increment in tetrahedral elements (typically 0.8-0.9).

## 4 Tutorial on using PARACHUTES

This tutorial illustrates the use of the simulation software and gives some guidelines for solving a typical test case involving a parachute-payload system. Please note that the procedure and parameters used here shall not be used as a default set-up valid for general test cases. The parameters and boundary conditions applied to each particular problem can depend on the model and the specific simulation scenario. Thus, the procedure and range of parameters required may differ from those used in this section.

The test case presented in this example involves a parachute-payload system which is released with no initial velocity in a constant air stream. The steady descend configuration of the system will be sought first, and then a deflection of the steering line will be applied in order to perform a right turn.
4.1 Model pre-process

The different steps required to prepare the simulation model are described in this section. These steps involve loading the problemtype and the geometric model, the assignment of boundary conditions and material properties and the mesh generation.

4.1.1 Loading the ProblemType

The PARACHUTES problemtype is loaded and assigned to the current project from the GiD data menu as shown in Figure 7. The program menus and the main toolbar will appear now on the GUI.

![Figure 7. Assign the PARACHUTES problemtype to the current project.](image)

4.1.2 Creating or importing the model geometry

The model geometry can be created inside GiD or imported from other CAD systems via one of the supported formats. Refer to GiD manual for instructions on loading geometry models into GiD [2]. In this tutorial, a generic parachute model has been created inside GiD using the CAD tools available. Since the solver does not compute the deployment and inflation stages, the simulation is started with an initial pre-inflated configuration (Figure 8). This is generated from the parachute fabric cut-patterns.
4.1.3 Assignment of boundary conditions

In this step the aerodynamic and structural boundary conditions are applied to the model. Starting with the aerodynamic conditions, the *trailing edge* is defined first. This condition must be applied on the lines corresponding to the actual trailing edge of the model, as shown in Figure 9. Ensure the lines of the trailing edge have their director vectors pointing in the same direction with “Utilities \(\rightarrow\) Swap normals \(\rightarrow\) Lines \(\rightarrow\) Select” menu, otherwise the aerodynamic solver will give bad results on the wake.
The **panel type** condition for the aerodynamic surfaces exposed to the wind is applied on the parachute canopy as shown in Figure 10 (thick panels). Only the external surfaces (i.e. upper and lower surfaces, inlet and tips) are included; the internal ribs must not be defined as aerodynamic panels. Note that since in this example the aerodynamics of the payload and the guidance unit will not be calculated (aerodynamic functions will be prescribed), these surfaces are not defined as aerodynamic panels. Similarly, the lateral tip stabilizers are also omitted from the aerodynamic computation (their contribution is not very significant). If these panels should be included in the computation, these must be marked as thin panels.
The **compute forces** condition (Figure 11) is assigned also on the external canopy surfaces (extrados, intrados, inlet, tip). Note that his condition is only valid for surfaces where the aerodynamics is resolved. In this example, the program will calculate the resultant aerodynamic forces for these surfaces and this information will be written in the forces output file with the id number 1. In order to separate the force contributions, different ids must be used for the surfaces. If these are not consecutive, the code automatically renumbers the ids and writes the translation table in the forces file.

The **Aerodynamic Forces (Experimental)** condition is assigned to the payload and the guidance unit (Figure 12). This condition allows prescribing an aerodynamic drag function for these bodies, which allows improving the aerodynamic modelling without increasing the computational cost of the problem. By the time being **only drag forces**
can be prescribed. The bodies using this condition must be solved as rigid in the structural computation, and their surface normal vectors must point outwards (i.e. into the fluid). To view the current surface normals, use the menu “View → Normals → Surfaces → Normal”. To modify all normals automatically so that they point outwards use the menu “Utilities → Swap normals → Surfaces → Make coherent” (manual fixing might be required depending on the model complexity). Note that the payload is numbered with ID = 1 and the control box with ID = 2. This numbering will be used again to identify both objects when assigning the corresponding aerodynamic drag functions. Note also that the aerodynamic forces condition must be assigned only to the external surfaces (i.e., all the surfaces directly in contact with the fluid).

Regarding the structural conditions, first we apply the **Face Pressure** condition to the **inlet surface of the canopy** (Figure 13). Since the aerodynamic model of the canopy must be closed, these panels cannot be omitted from the model. Hence, in order to prevent these panels from interfering with the structural behavior, a condition of zero pressure is applied. This will ensure that the inlet will not be subject to any forces, thus effectively rendering it as a structural aperture on the canopy. In addition, the mechanical properties of these panels will be chosen in such a way that the load bearing capacity be negligible in comparison with the rest of the canopy (low stiffness and thickness).
The payload and the guidance unit are considered as rigid bodies, therefore the **Rigid Body** condition is assigned to them (Figure 14). Both objects are identified by their ID number (1 for the payload and 2 for the guidance unit). These values must be coincident with those employed in the definition of the aerodynamic force conditions.

In order to perform the right turn manoeuvre, a **Cable Strain** condition is applied to the lower steering line on the canopy right side. In our case, a 20% shortening (-0.2 epsilon deformation) is assigned. The deformation will start at time $t = 10\,s$, it will take 5 seconds to shorten, then it will be maintained for 5 seconds, and finally it will be slowly released in 5 seconds. Note that the deformations must be applied slowly (using realistic linear cable speeds) because any abrupt change on the line length may cause important accelerations affecting the solver convergence and stability.
Figure 15. *Cable Strain* condition assigned to the right guidance cable. The cable will suffer a 20% shortening during 5 seconds.

### 4.1.4 Defining the model materials

A specific material will be assigned to each part of the parachute in this section. To this end, the problemtype has different templates to define materials; namely: *membrane*, *cable*, *reinforcement* and *solid* (see the Program Theory Manual [1] for a description of the models employed). The default templates define a type of material and associate a set of physical and mechanical properties, e.g. density, Young’s modulus, etc. Note that each entry on the materials list will ultimately be a distinct material applied in the model, thus the user must create as many materials as required using the available templates, with the “New Material” button on the menu window.

In the present example, the canopy of the parachute (including the internal ribs, tips, inlet and stabilizers) is defined as a single *Membrane* material, applied on the *surface elements* mentioned before. The default entry for the *Membrane* is used for convenience. The material properties used for this parachute are depicted in Figure 16. Recall that the program requires that the set of units employed in the model geometry, material properties and simulation parameters is consistent (see Section 2.1.1).
The canopy seams and reinforcement tapes are defined as a **Reinforcement** material, using again the default entry for convenience. This material is applied on the *line elements* of the canopy as seen in Figure 17. It should be noted that the program internally treats the reinforcement as a cable element.

The payload and the guidance unit are defined using the **Solid** material. For the sake of simplicity, in this tutorial both objects will be considered to be made of the same material. The material is assigned to the *volume elements* of the payload and guidance box as seen in Figure 18.
Figure 17. *Reinforcement* material assigned to the canopy seams.

Figure 18. *Tetra* material assigned to the payload and guidance box.
The parachute chords are defined as **Cable** material. The material is assigned to the *line elements* of both the suspension and the steering lines, as seen in Figure 19.

![Figure 19. Cable material assigned to the parachute cords and the guidance cables.](image)

The cables of the payload are made of a different material than the parachute cords and they are also considerably thicker, therefore a new material of type *Cable* must be created. This can be done via the **new material** button on the materials window’s toolbar, which essentially duplicates the current material template. In this example, a *Cable_Payload* material is generated and assigned to the *elements* corresponding to the payload cables (see Figure 20).
It is important to note that in this example, the damping forces are calculated using the relative velocities mode, which is the default in PARACHUTES (see Section 3.2). Thus, larger values of the damping parameter $\alpha$ are used without affecting the overall behavior of the structure.

4.1.5 Meshing the model

Once the boundary conditions and the materials have been assigned, the model geometry must be discretized (or meshed). Take into account that any change in either the boundary conditions or the materials requires re-meshing the model, as the assigned values are applied on the nodes only through the meshing process. Users should refer to GiD manual [2] for specific details on how to configure and mesh a particular geometry. In this example, we are not going to focus on determining appropriate mesh sizes and transitions. This depends on each particular problem to be solved and should be determined on the basis of the underlying physics and scope of the numerical model. The general criteria followed in aerodynamic and structural analyses also applied here. Some considerations regarding the geometric entities that must be meshed and the type of elements to be used are given below.
Starting with the canopy, the discretization of the latter is required for both aerodynamic and structural calculations, and this can be done with 3-node triangular or 4-node quadrilateral elements. Since the latter have a better performance from the point of view of the aerodynamics, this type of element is adopted for the canopy surfaces exposed to the wind (the only parts processed by the aerodynamic solver). Then, the program automatically converts these elements into triangles for the structural computation. The internal ribs, tips and stabilizers are meshed with triangular elements. A view of the resulting mesh can be seen in Figure 21 (initial un-deformed configuration). Since the triangles and quadrilaterals behave as flat panels, the element size must be small enough to reproduce the curvature of the parachute cells and the solution gradients properly, keeping the model size and computational cost within reasonable limits.

Note that GiD meshes by default all surfaces (this can be changed using the menu “Mesh → Mesh_Criteria → NoMesh → surfaces”). In the case of the reinforcement tapes integrated into the canopy, these need to be mesh separately from the canopy fabric. This behavior is not default for GiD, thus it must be indicated using the menu “Mesh → Mesh_Criteria → Mesh → lines” for the selected reinforcement tapes and seams.

Figure 21. Parachute mesh detail. Note the different element types used for the canopy and the tip and stabilizers (quadrilateral and triangles).

The payload and the guide unit are meshed with solid tetrahedra elements (see Figure 22). In this example these bodies will be modelled as rigid; therefore, the number of elements is kept to a minimum to represent the geometry under study. Regarding the
exterior surfaces exposed to the wind, these will not be calculated by the aerodynamic
solver (its aerodynamics will be accounted for through prescribed aerodynamic
functions). Hence, it is necessary that these surfaces are not meshed. This can be
done via the menu “Mesh → Mesh criteria → No mesh → Surfaces”.

4.2 Configuring the simulation (Problem Data)

Once the geometric discretization of the model is completed, the simulation parameters
must be configured before launching the simulation. These parameters affect only the
simulation conditions and the solver options, not the actual model properties. Thus, the
geometry does not need to be re-meshed whenever the problem data is modified.

In this example, the simulation is run during 3000 aerodynamic steps with a time
increment of 0.5 seconds. Note that in coupled simulations, this value is only a target
(or limit) time increment; the actual value will be variable and depends on the stopping
criteria adopted in the structural solver (e.g. maximum displacement allowed per step).
Using the parallel capabilities of the aerodynamic solver, four cores are used in order to
speed up the simulation. The structural solver runs every aerodynamic step for a
maximum of 10000 iterations per run or a maximum displacement of 0.2 (whichever
comes first). The result files will be printed every 10 aerodynamic steps.
The parachute reference length and surface are $6 \, \text{m}$ and $90 \, \text{m}^2$, respectively. The parachute system is launched with no initial velocity in a $[0.5,0,0] \, \text{m/s}$ wind environment (the coordinate axes refer to the definition of the model geometry).

In order to minimize the fluttering on the trailing edge (particularly at the starting moment), the *Trailing edge correction* parameter is set to 0.3. Finally, the *BiCG* iterative solver is used for solving the aerodynamics due to its low memory requirement. All the other parameters are left with their default values defined in the *problemtype* menus.

**4.3 Executing and monitoring the simulation**

Once the problem has been configured, the simulation can be launched. This can be done alternatively by: "Calculate $\rightarrow$ Calculate" menu (Figure 23), the "Calculate $\rightarrow$ Calculate window $\rightarrow$ Start" menu, or pressing the *Calculate* shortcut (default to F5 key).

Either way, GiD compiles the simulation parameters and geometry files, generates the program input files and calls the solver from the user’s current project directory.

It should be noted that the program requires two ASCII input data files. First, a file named *controls.dat* where all the simulation and control parameters are specified; and second, a file named *geodata.dat* which contains the geometry of the model and the boundary conditions.

![Figure 23. Calculate menu.](image)

If no errors are found during the generation of the input data files and solver call, the simulation will start. Otherwise error message will be displayed. The processes launched by GiD at this point are depicted in Figure 24.

![Figure 24. Processes launched by GiD during simulation (Win64 platform).](image)
During execution, a program screen log file can be visualized in order to monitorize the performance of the simulation. This can be done via “Calculate → View process info” menu, or alternatively by “Calculate → Calculate window → Output view”. This information can be useful to check the simulation status or identify potential problems. Furthermore, a simulation can be stopped at any time using the menu “Calculate → Cancel process”, or “Calculate → Calculate window → Terminate”.

The simulation launched in this tutorial took roughly 24 hours on an Intel i7 860 processor @ 2.8GHz (1MB L2 cache) with 4 running cores. The average CPU time per step ranges between 20-40 seconds for the aerodynamic calculation and 5-10 seconds for the structural one (see Figure 25). Note that these values may vary considerably with the status of the simulation (instant configuration), the mesh density, the selected aerodynamic solver and the user hardware. It is possible to observe in Figure 25 the initial transitory stage, approximately until step 50, and the right-turn maneuver performed between iterations 1000 to 2000.

Table 1 presents some information regarding the computational requirements of the different algebraic solves available in PARACHUTES. Note that the direct solvers activate their multi-threading capabilities automatically (results are presented for 4 running cores).
<table>
<thead>
<tr>
<th>RAM memory used [MBytes]</th>
<th>Direct</th>
<th>BiCG</th>
<th>LU</th>
<th>Combined</th>
</tr>
</thead>
<tbody>
<tr>
<td>3100-5200</td>
<td>1036</td>
<td>1044</td>
<td>1044</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>CPU time per iter (1 core) [sec]</th>
<th>Direct</th>
<th>BiCG</th>
<th>LU</th>
<th>Combined</th>
</tr>
</thead>
<tbody>
<tr>
<td>-</td>
<td>-</td>
<td>40</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>CPU time per iter (2 cores) [sec]</th>
<th>Direct</th>
<th>BiCG</th>
<th>LU</th>
<th>Combined</th>
</tr>
</thead>
<tbody>
<tr>
<td>-</td>
<td>-</td>
<td>22</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>CPU time / iter (4 cores) [sec]</th>
<th>Direct</th>
<th>BiCG</th>
<th>LU</th>
<th>Combined</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.5-30</td>
<td>12</td>
<td>17</td>
<td>8-24</td>
<td></td>
</tr>
</tbody>
</table>

Table 1. Performance of the algebraic solvers (CPU time and RAM memory usage).

4.4 Post-processing results

The GiD post-processor is used in PARACHUTES for the analysis and visualization of the numerical results. This can be accessed at any time via “Files → Postprocess” menu, or using the “Post-process” menu bar button. Note that if the simulation is still running, GiD will load all the results up to the last availables. Once in post-process mode, a result file can be loaded via “File → Open…” menu. The result files available are those with extension `_aero.post.res` for the aerodynamics, and `_pumi.post.res` for the structure, as shown in Figure 26. Since the aerodynamic and structural grids are different (not the structural parts are computed by the aerodynamic solver), only one file must be selected at a time for post-processing. The user should consult the GiD manual [2] for the tools and visualization options available.

![Figure 26. Load post-process result files.](image)

It is important to note that the current version of PARACHUTES writes the output results in ASCII files. Hence, the size of the output files can be considerable for runs involving a large simulation time. In such cases, the frequency used to print these files should be adjusted to the minimum required to perform the desired analysis. Future improvements will allow writing the output files using binary formats, reducing the file storage requirements (this option is available in GiD to load or export results files).
4.4.1 Example of simulation results

Some results from the example simulation are presented below. These results are merely shown for demonstration purposes and do not imply any guideline for an actual aerodynamic or structural analysis.

The aerodynamic results file (Parachute_aero.post.res) is selected and loaded. The aerodynamic *.res file contains the values for the coefficient of pressure, velocities, doublet and wake doublet for each time step of the simulation. The corresponding mesh file (Parachute_aero.post.msh) is also loaded automatically by GiD. The aerodynamic *.msh file contains the model’s deformed mesh for each time step of the simulation. Once loaded, the time step of interest can be selected within “View results → Default Analysis/Step → Load Analysis” menu. The time step can also be set with the animation window (see Section 4.4.2).

The contour map of the coefficient of pressure from the quadrilateral nodes (canopy) can be shown via “View results → Contour fill → Cp → Quad” menu, or from the post-process toolbar (Figure 27). The $C_p$ contour map for the Triangle nodes (tips, stabilizers, etc) can be likewise shown via “View results → Contour fill → Cp → Tria” menu. The options for all the plots (limits, steps, colors, etc.) can be accessed on the “Options” menu.

![Figure 27. Cp contour map for the quadrilateral nodes on the canopy.](image)

The arrow map for the velocity magnitude distribution on the canopy quad nodes can be shown via “View results → velocity → Quad → |velocity|” menu. Likewise, the X, Y, Z components can be shown separately (see Figure 28), as well as the velocities for the triangle nodes. Once loaded, GiD also asks for an optional scaling factor on the command line.
Figure 28. Velocity (z-component) magnitude arrow map for the quadrilateral nodes on the canopy.

Time-dependent plots can be extracted using the submenus on “View results → Graphs”. In Figure 29, the point-graph for the coefficient of pressure $C_p$ on a randomly picked element of the canopy is shown. GiD also allows saving the graph coordinates in separated text files for other analysis purposes.

Figure 29. Evolution of the $C_p$ for a given canopy panel.

The structural result file (*Parachute_pumi.post.res*) contains the values for the cable stress, displacement, membrane stress, relative position, solid stress and velocities. The corresponding mesh file (*Parachute_pumi.post.msh*) is also loaded automatically by GiD. The structural *.*.msh file contains the model’s initial non-deformed mesh. The contour map for the canopy’s membrane stress (Sxy component) is shown in Figure 30. It is important to note in this case that by default GiD will show the un-deformed (initial) configuration. In order to apply the calculated deformations use the menu View_Results → Deformation → Displacement, and select a proper scale factor (1 for no scaling).
Figure 30. Membrane Stress magnitude on the *membrane* elements of the parachute.

The file *Parachute.velocity.dat* contains a list of step, time, the velocity components of the center of mass (see Figure 31) and the model inertia components. The parachute glide slope angle can be extracted from the velocity components (see Figure 32).

![Figure 31. Modulus of the components of the center of mass velocity.](image)

![Figure 32. Parachute glide slope angle.](image)
The file *Parachute.forces.dat* contains a list of step, time, dynamic pressure and several coefficients of forces and moments. Using the value for the glide angle and the coefficients of forces of the canopy and the cables, the coefficients of Lift and Drag can be estimated as seen in Figure 33.

![Figure 33. Coefficients of Lift and Drag of the parachute.](image)

### 4.4.2 Animations

GiD allows animating the results using the Animate tool (“Window → Animate…” menu). Each frame can be saved as an image, or the entire simulation as a video file. This tool can also be used to control the time step of interest in an interactive way.

### 5 Registering PARACHUTES

The problemtype PARACHUTES can be executed in evaluation or professional mode. The evaluation mode is only for testing purposes and is restricted to small models (these cannot exceed 500 nodes or elements). The professional mode allows profiting from all capabilities of the simulation software and requires a license password. This is a 24 characters code which must be introduced in the GiD menu “Help → Register_problemtype” (in some operating systems GiD must be executed as an administrator to store the license password). The code verifies the license status at the beginning of the calculation, if no valid password is found the default running mode is evaluation.

In order to obtain the license password you must contact your software dealer with the following machine information: `machine_name`, `operating system` and `sysinfo`. These data are displayed in the same GiD register_problemtype windows. In addition, the code also shows this information at the beginning of the calculation, when the license status is verified (see Figure 34).
6 Conclusions

The graphical user interface developed for the simulation program PARACHUTES has been described in detail in this document. An application test case has also been presented to illustrate the usage and the performance of the program. Although applied to a specific simulation case, the example provided is representative enough of the typical boundary conditions and parameters used in parachute simulation. Details of the computational performance and requirements were also given for the case under study. The present user interface (2.0) includes most of the program capabilities included in its research version.

The development of PARACHUTES is currently under way and several improvements and validation tasks are being carried out. This work is mainly focused on enhancing modelling capabilities and computational performance (CPU-time and memory requirements). These improvements will be included in future releases of the program interface as soon as they are successfully tested.

References